Обновление до 3.0.5.0

Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: Пред. 1 2 3 4 След.
RSS
Обновление до 3.0.5.0
 
Спасибо, Вы предусмотрите всё таки каку нибудь реакцию на нажатие. а то я жму вроде что то промелькивает а работает или нет неизвестно.
 
проблема в регламентном задании! в рабочее время мы не используем его, после рабочего времени регламентное задание выполняется до утра - до начала рабочего времени. видимо отработать не успевает и регламентное начинает работать дальше в рабочее время. в связи с этим начинают выскакивать ошибки транзакций!
вот ошибка - Ошибка регистрации объекта: Документ.РасчетПриУвольненииРаботникаОрганизаций
{ОбщийМодуль.внЖурналРегистрацииСервер.Модуль(215)}: Ошибка при вызове метода контекста (Выполнить)
Выборка = Запрос.Выполнить().Выбрать();
по причине:
Ошибка выполнения запроса
по причине:
Конфликт блокировок при выполнении транзакции:
Microsoft SQL Server Native Client 11.0: Lock request time out period exceeded.
HRESULT=80040E31, SQLSrvr: SQLSTATE=HYT00, state=33, Severity=10, native=1222, line=1
и другие ошибки такого же характера. скажите есть возможность как то прекратить это регламентное задание - в обработке консоли заданий - задание выполняется. учтите это в след обновлении - чтобы к примеру - можно было поставить галочку размер пакета к примеру 100 - количество пакетов для переброса в хранилище 500 000 - чтобы эти пакеты успевали переброситься за ночь и не запускалось регламентное в рабочее время и не выскакивали ошибки транзакции!!! Спасибо!
 
Добрый день.
Настройте регламентное задание таким образом, что бы оно работало только ночью, такая возможность у вас и так есть.
Автоматизация сегодня - Ваш успех завтра
 
я и настраиваю таким образом что запускать к примеру после 19ч и завершать 7ч. но оно продолжает дальше работать! т.е. не прекращается - запустилось и работает! пока не перебросит видимо все записи.
 
Устанавливаете в регламентном задании в настройках расписания "Завершать после"?
Автоматизация сегодня - Ваш успех завтра
 
естественно!
 
ОК. Обязательно что-нибудь к следующему релизу по этому поводу придумаем.
Спасибо за обращение.
Автоматизация сегодня - Ваш успех завтра
 
Модифицировал в регламентном задании Удаление событий следующим образом:

Если УдалитьСобытия Тогда
N=0;
Обработано = 0;
Пока Выборка.Следующий() Цикл
Попытка
Об = Выборка.Ссылка.ПолучитьОбъект();
Об.Удалить();
КоличествоОбработанных = Выборка.Количество();
//
N=N+1;
Обработано = Обработано + 1;
Исключение
ЗаписьЖурналаРегистрации("ВнешнийЖурналРегистрации", УровеньЖурналаРегистрации.Ошибка, , ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));
КонецПопытки;
Если N > 500 Тогда

ЗаписьЖурналаРегистрации("ВнешнийЖурналРегистрации", УровеньЖурналаРегистрации.Предупреждение,,,"Задержка выполнения, осталось: "+Строка(КоличествоОбработанных - Обработано));
Старт = ТекущаяДата();
Задержка = Старт - ТекущаяДата();
Пока Задержка <= 300 Цикл
Задержка = ТекущаяДата()- Старт;
КонецЦикла;
N=0;
КонецЕсли;
КонецЦикла;
Иначе
КоличествоОбработанных = Выборка.Количество();
КонецЕсли;


Параметры "регулирую" вручную... Пришлось сделать паузы, так как удаление более 2 млн. записей. Помогло решить проблему "забивания" SQL и снизило нагрузку на дисковую подсистему. Вариант не идеальный... но помог...
В стандартной реализации все базы вставали колом.

 
можно поподробнее? это к чему относится? к моему вопросу выше это решает проблему?
 
Кусок выше решает проблему (в моем случае), когда регламентное задание не завершается в отведенное ему время по причине большого объема данных к удалению (у меня это более 1.5 млн. записей. Более того, опять же в моем случае, запуск регламентного задания полностью вешает остальные базы, так как очень сильно возрастает нагрузка на дисковую подсистему и она не справляется с объемом задач на чтение/запись, увеличивается очередь задач на SQL.
Поэтому была сделано следующее... система выбирает все данные к удалению на момент запуска регламентного задания, но удалять начинает не сразу все подряд а порциями по 500, 1000 записей... между удалением интервал в 5 минут. Все это индивидуально, например, сейчас у меня отрабатывает по 1000 записей с интервалом в 5 минут. При такой модификации сейчас проблем с производительность не наблюдаю
Страницы: Пред. 1 2 3 4 След.
Читают тему