Конфликт с "Набор.

Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Конфликт с "Набор.
 
В определенных случаях при в модуле "внОбщийМодуль" возникает конфликт с наименованием в запросе "Набор" (строка 4650).

Вышли из положения скорректировав "Набор" на "внНабор"
 
Вот так изменили?

// Добавляем дополнительные свойства
Запрос = Новый Запрос;
УсловиеОтбора = "";
ПолноеИмя = Источник.Метаданные().ПолноеИмя();

Для каждого ЭлементОтбора Из Источник.Отбор Цикл

Если НЕ ЭлементОтбора.Использование Тогда
Продолжить;
КонецЕсли;
Если НЕ ПустаяСтрока(УсловиеОтбора) Тогда
УсловиеОтбора = УсловиеОтбора + " И ";
КонецЕсли;
УсловиеОтбора = УсловиеОтбора +" внНабор." + ЭлементОтбора.Имя + " = &" + ЭлементОтбора.Имя;
Запрос.УстановитьПараметр(ЭлементОтбора.Имя, ЭлементОтбора.Значение);

КонецЦикла;

Если НЕ ПустаяСтрока(УсловиеОтбора) Тогда
УсловиеОтбора = " ГДЕ " + УсловиеОтбора;
КонецЕсли;

Запрос.Текст = "ВЫБРАТЬ * ИЗ " + ПолноеИмя + " КАК внНабор " + УсловиеОтбора;
ТЗРегистра = Запрос.Выполнить().Выгрузить();

А что за конфликт в запросе? Какая ошибка была?
Автоматизация сегодня - Ваш успех завтра
 
Да, изменили именно так.

Возможно проблема такая только у нас, но у нас в системе встречается Регистр в котором есть измерение Набор, а также табличная часть в документе.
Ошибка "Неоднозначное поле Набор.Документ"
 
Ждите в следующем обновлении
Автоматизация сегодня - Ваш успех завтра
Страницы: 1
Читают тему