Ошибка в обработке ИмпортИзActiveDirectory

Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Ошибка в обработке ИмпортИзActiveDirectory
 
Доброго времени суток.

Обнаружена ошибки импорта email в обработке ИмпортИзActiveDirectory в редакции 3.0 (3.0.9.2), а именно - загружает телефон вместо email.

Если ЗначениеЗаполнено(Стр.Телефон) Тогда
СтрокиТелефон = ПользовательОбъект.КонтактнаяИнформация.НайтиСтроки(Новый Структура("Вид", Справочники.ВидыКонтактнойИнформации.ТелефонПользователя));
Если СтрокиТелефон.Количество() > 0 Тогда
СтрокаТелефон = СтрокиТелефон[0];
Иначе
СтрокаEmail = ПользовательОбъект.КонтактнаяИнформация.Добавить();
СтрокаEmail.Вид = Справочники.ВидыКонтактнойИнформации.ТелефонПользователя;
КонецЕсли;
СтрокаEmail.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон;
СтрокаEmail.Представление = Стр.Телефон;
СтрокаEmail.НомерТелефона = Стр.Телефон;
КонецЕсли;


Я думаю, должно быть так -

Если ЗначениеЗаполнено(Стр.Телефон) Тогда
СтрокиТелефон = ПользовательОбъект.КонтактнаяИнформация.НайтиСтроки(Новый Структура("Вид", Справочники.ВидыКонтактнойИнформации.ТелефонПользователя));
Если СтрокиТелефон.Количество() > 0 Тогда
СтрокаТелефон = СтрокиТелефон[0];
Иначе
// { Дмитрий [27.05.2014]
//СтрокаEmail = ПользовательОбъект.КонтактнаяИнформация.Добавить();
//СтрокаEmail.Вид = Справочники.ВидыКонтактнойИнформации.ТелефонПользователя;
СтрокаТелефон = ПользовательОбъект.КонтактнаяИнформация.Добавить();
СтрокаТелефон.Вид = Справочники.ВидыКонтактнойИнформации.ТелефонПользователя;
// } Дмитрий [27.05.2014]
КонецЕсли;
// { Дмитрий [27.05.2014]
//СтрокаEmail.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон;
//СтрокаEmail.Представление = Стр.Телефон;
//СтрокаEmail.НомерТелефона = Стр.Телефон;
СтрокаТелефон.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон;
СтрокаТелефон.Представление = Стр.Телефон;
СтрокаТелефон.НомерТелефона = Стр.Телефон;
// } Дмитрий [27.05.2014]
КонецЕсли;
 
Добрый день. Спасибо создали тикет FS#185
Автоматизация сегодня - Ваш успех завтра
Страницы: 1
Читают тему