Юрий Чебурков (Все сообщения пользователя)

Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Выбрать дату в календареВыбрать дату в календаре

Страницы: 1 2 3 След.
Обновление до 3.0.5.0
 
admin пишет:Добрый день и подсистема не "сырая" эта проблема только в последней версии подсистемы.
Фикс можете добавить уже сейчас и ждать обновления.
Фикс от блокировок следующий.
0) Добавить в регистр сведений "внКэшЖурналаРегистрации" измерение "Ключ" с типом "УникальныйИдентификатор".
1) В регистре сведений "внКэшЖурналаРегистрации" измерение "НомерЗаписи" увелчичить размер типа с 10 до 15 знаков.
2) В общем модуле "внЖурналРегистрацииСервер" процедуру "РегистрацияИзмененияОбъекта" поменять на следующую:

Все. Блокировок больше не будет.

Вопрос, надо ли что-то изменить в Хранителе, связанное с размерностью полей или типом? Так как после изменения не переносятся именно изменения с новыми данными. Старые все перенеслись и по ним не возникает вопросов.
Видимо та ошибка, а она в стандартный журнал регистрации пишется именно как ошибка, а не информационное сообщение, сообщает именно о том, что по какой-то причине не может перенести данные.

Обновление до 3.0.5.0
 
Остановка переноса кэша записей в Хранитель. Произошла попытка отправки ранее удаленной записи.

Куда копать?
Обновление до 3.0.5.0
 
Коллеги, есть техническое решение, готов обменять его на продление подписки на обновление на 1 год.
Обновление до 3.0.5.0
 
Это речь про источник изменений? или уже про сам хранитель?
Сейчас мы наблюдаем в базе источнике - проблему связанную с блокировками. Сегодня-завтра постараюсь описать суть...
Обновление до 3.0.5.0
 
Нет, не получается...
Удаление записей происходит в хранителе, а не в базе, в которой регистрируются изменения.
Изменения перекидываются каждые 5 минут. Сейчас авторы-разработчики уже сделали, чтобы перекидывалось по 100 записей в хранитель и их количество можно менять в настройках
Обновление до 3.0.5.0
 
Кусок выше решает проблему (в моем случае), когда регламентное задание не завершается в отведенное ему время по причине большого объема данных к удалению (у меня это более 1.5 млн. записей. Более того, опять же в моем случае, запуск регламентного задания полностью вешает остальные базы, так как очень сильно возрастает нагрузка на дисковую подсистему и она не справляется с объемом задач на чтение/запись, увеличивается очередь задач на SQL.
Поэтому была сделано следующее... система выбирает все данные к удалению на момент запуска регламентного задания, но удалять начинает не сразу все подряд а порциями по 500, 1000 записей... между удалением интервал в 5 минут. Все это индивидуально, например, сейчас у меня отрабатывает по 1000 записей с интервалом в 5 минут. При такой модификации сейчас проблем с производительность не наблюдаю
Обновление до 3.0.5.0
 
Модифицировал в регламентном задании Удаление событий следующим образом:

Если УдалитьСобытия Тогда
N=0;
Обработано = 0;
Пока Выборка.Следующий() Цикл
Попытка
Об = Выборка.Ссылка.ПолучитьОбъект();
Об.Удалить();
КоличествоОбработанных = Выборка.Количество();
//
N=N+1;
Обработано = Обработано + 1;
Исключение
ЗаписьЖурналаРегистрации("ВнешнийЖурналРегистрации", УровеньЖурналаРегистрации.Ошибка, , ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));
КонецПопытки;
Если N > 500 Тогда

ЗаписьЖурналаРегистрации("ВнешнийЖурналРегистрации", УровеньЖурналаРегистрации.Предупреждение,,,"Задержка выполнения, осталось: "+Строка(КоличествоОбработанных - Обработано));
Старт = ТекущаяДата();
Задержка = Старт - ТекущаяДата();
Пока Задержка <= 300 Цикл
Задержка = ТекущаяДата()- Старт;
КонецЦикла;
N=0;
КонецЕсли;
КонецЦикла;
Иначе
КоличествоОбработанных = Выборка.Количество();
КонецЕсли;


Параметры "регулирую" вручную... Пришлось сделать паузы, так как удаление более 2 млн. записей. Помогло решить проблему "забивания" SQL и снизило нагрузку на дисковую подсистему. Вариант не идеальный... но помог...
В стандартной реализации все базы вставали колом.

Импорт в Хранитель журнала регистрации
 
Работать перестало буквально после пезагрузки ПК, до этого импорт шел....
Необходимы Integration Services ? запущенные как служба?
Импорт в Хранитель журнала регистрации
 
Добрый день,

при попытке импорта из старой БД в хранитель журнала возникает ошибка "Недопустимая строка с указанием класса" (скрин во вложении)
Такая же ошибка возникает при перевыборе идентификатора ИБ

Хранитель журнала регистрации, редакция 1.0 (1.0.2.3)

Обновление до 3.0.5.0
 
admin пишет:Добрый день. Из подсистемы данный регистр не удаляется. Был удален регистр сведений внИзменения.

я имел в виду основную базу в которой генерируются изменения.

п.3 инструкции
Страницы: 1 2 3 След.