Ошибка: Закройте перед проведением все карточки номенклатуры

Поиск  Пользователи  Правила 
Закрыть
Логин:
Пароль:
Забыли свой пароль?
Регистрация
Войти
 
Страницы: 1
RSS
Ошибка: Закройте перед проведением все карточки номенклатуры
 
Есть документ Заказ, на его основе создал документ поступление. При попытке сохранить - ошибка
Закройте перед проведением все карточки номенклатуры, которые используются в документе!
{ОбщийМодуль. ОбщегоНазначения. Модуль (1736)}: Ошибка при вызове метода контекста (ЗаписатьВФорме): Не удалось записать: "Поступление"!
 
Да действительно такая ошибка есть...
Для того, что бы исправить эту проблему сейчас сделайте следующее:
1) Откройте конфигурацию в режиме конфигуратора
2) Включите возможность изменения конфигурации как по ссылке

3) Щелкните правой кнопкой по документу "Поступление" и найдите вот такой блок:
Код
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   ОбработкаТабличныхЧастей.ПриЗаписиПроверитьСтавкуНДС(ЭтотОбъект, Номенклатура);
   ОбработкаТабличныхЧастей.ПриЗаписиПроверитьСтавкуНДС(ЭтотОбъект, Услуги);
   СуммаДокумента = ОбработкаТабличныхЧастей.ПолучитьСуммуДокументаСНДС(ЭтотОбъект);
   
   // Запись в карточку поставщика
   Попытка
      Для Каждого Строки Из Номенклатура Цикл
         Если Строки. КарточкаНоменклатуры. Поставщик <> Контрагент Тогда
            ОбъектКарточка                = Строки. КарточкаНоменклатуры. ПолучитьОбъект();
            ОбъектКарточка.Поставщик       = Контрагент;
            ОбъектКарточка.ДатаПоступления = Дата;
            ОбъектКарточка.Записать();
         КонецЕсли;
      КонецЦикла;
   Исключение
      ОбщегоНазначения. СообщитьОбОшибке("Закройте перед проведением все карточки номенклатуры, которые используются в документе!");
      Отказ = Истина;      
   КонецПопытки;
КонецПроцедуры


Замените его на следующий:
Код
Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   ОбработкаТабличныхЧастей. ПриЗаписиПроверитьСтавкуНДС(ЭтотОбъект, Номенклатура);
   ОбработкаТабличныхЧастей. ПриЗаписиПроверитьСтавкуНДС(ЭтотОбъект, Услуги);
   СуммаДокумента = ОбработкаТабличныхЧастей. ПолучитьСуммуДокументаСНДС(ЭтотОбъект);
   
   // Запись в карточку поставщика
   Попытка
      Для Каждого Строки Из Номенклатура Цикл
         Если ЗначениеЗаполнено(Строки. КарточкаНоменклатуры) Тогда
            Если Строки.КарточкаНоменклатуры.Поставщик <> Контрагент Тогда
               ОбъектКарточка = Строки. КарточкаНоменклатуры. ПолучитьОбъект();
               ОбъектКарточка.Поставщик = Контрагент;
               ОбъектКарточка.ДатаПоступления = Дата;
               ОбъектКарточка.Записать();
            КонецЕсли;
         КонецЕсли;
      КонецЦикла;
   Исключение
      ОбщегоНазначения. СообщитьОбОшибке("Закройте перед проведением все карточки номенклатуры, которые используются в документе!");
      Отказ = Истина;      
   КонецПопытки;
КонецПроцедуры

После этого сохраните конфигурацию.

В следующем релизе эта ошибка будет исправлена. Спасибо.
Автоматизация сегодня - Ваш успех завтра
 
Спасибо, все получилось.
Страницы: 1
Читают тему